Crashlytics dla ndk nie mogą uzyskać dostępu do systemu rozwijanego

kathy zhou 07/26/2017. 1 answers, 97 views
android-ndk android-ndk native crashlytics google-fabric

Crashlytics dla ndk nie może uzyskać dostępu do rozwijanego systemu z informacjami o błędzie: Nie udało się znaleźć żadnych przydatnych bibliotek odwijania na urządzeniu, a powrót do prostego rozwijania

Być może ta awaria spowodowała, że ​​dostaliśmy tylko jedną linię dla rodzimej awarii.

Moje urządzenie to Nexus 6 z platformą 7.1.1

1 Answers


Mike Bonnell 07/26/2017.

Mike z Fabric tutaj. Tak, jeśli nie jesteśmy w stanie znaleźć libcorkscrew i libunwind, przełączamy się na własny, prosty odwijacz. Prosty mechanizm odwijający jest w stanie uzyskać najwyższą klatkę podczas awarii, dlatego widzisz takie zachowanie. Planujemy to ulepszyć.

4 comments
1 kathy zhou 07/27/2017
Dziękuję za szybką odpowiedź. Moje dalsze pytanie brzmi: czy istnieje jakieś rozwiązanie tego problemu? Czy możemy dodać libunwind do naszego projektu, aby rozwiązać ten problem?
Mike Bonnell 07/28/2017
Niestety nie w tej chwili, ale jak już wspomniałem, pracujemy nad ulepszeniem tego.
Maris B. 08/23/2017
@MikeBonnell - jakikolwiek ETA na temat "czynienia tego lepiej" ?. Miesiąc później i nadal "Nie udało się znaleźć żadnych przydatnych rozwijanych bibliotek na urządzeniu, wracając do prostego rozwijania" w systemach Android 5.0 i Android 7.0
Mike Bonnell 08/23/2017
Nie mam ETA, które mogę udostępnić publicznie. Jeśli jesteś zainteresowany testowaniem czegokolwiek, nad czym pracujemy, to wyślij e-mail do support (at) fabric (dot) io z odniesieniem do tego wątku.

Related questions

Hot questions

Language

Popular Tags